DJI Drone Help Forum

Air 2 with latest iPad Mini-No Audible Notifications

Hello everyone. I hope those that got their new Air 2 are enjoying it as much as I am.

Question… When I use my new iPad mini, I do not get audible conformations or warnings.
“The Home point has been updated, please check it on the map", "go home”, “landing”, obstacles warning sound, etc. I confirmed it’s not the cable. Volume is turned up. Is there a setting I’m missing? Thanks in advance for your help!

Maybe, maybe not! How’s that for an answer. I had problems with my Mavic Air and iPad Mini 5 recently. My cure was excessive but it finally worked. First let me explain what my problem was. I had made sure all other apps not needed for my purpose were killed. Good. Then I attempted to unlock for flight in a class C airspace. Here’s where my problems began. Although I can use either my iPad Mini 5 or my Samsung TabA, I choose to use my Mini 5 due to ease of use, specifically when it comes to killing conflicting apps. Simply swipe up. OK, Mini 5 it is! Go 4 loaded and allowed me to check all screens and it did give me warning, rightly so, of classed airspace. Remember, I had LAANC and DJI unlock approval. Problem was Go 4 would not proceed with unlocking. 12 times or more,nand no go! Waited 30 minutes for email help and ended up with an idiot! DJI finally told me I needed to obtain their unlock approval. Duhhhh. That was all explained previously about 4 or 5 times. Long story short. I finally deleted the app and reinstalled no less than 3 times. Worked like a charm on the 3rd install. Learned later, by various web surfing, that Android is more current with DJI than ios is. That’s my story and I’m sticking to it! I prefer the iOS ease of use.
My connections are: GPS device is my Samsung Mote 8, iPad Mini 5 is Bluetooth linked to the phone for gps, Go 4 control.
When I fly in classed airspace with Litchi it becomes even more confluted.