DJI Drone Help Forum

Return to Home not working - including log

Simply for the sake of asking the question. Are you using the APP RTH or the RC RTH? Not that it should make any difference, but according to the data you are using the APP RTH.

I have tried both with same result, but I believe in the two logs I have posted, I used the app RTH.

I don’t know if the tablet .DAT has the front sensor data. But, why don’t you post it so we can take a look. You might have to use Dropbox or a sililar public sharing site.

Happy to share any data I have to resolve this. This is the full export of the Flightrecords folder from the ipad.

There is an empty folder “MCDatFlightRecords”, which I fear is what you are asking for. :frowning:

Yes, you fear correctly. The instructions for retrieving the P4 .DAT are here.
Retrieving a V3 .DAT File from the AC

You could also try calibrating the forward vision system. Not that I think it needs calibrating but that would insure that it’s working OK. This problem is very similar to the situation where the P4 is facing into the sun which causes the forward vision system to think there is an obstacle. The rthOAenabled is set to false so this shouldn’t matter but it’s worth checking. Did you set OA on RTH to false?

I am having the exact same issue! I hadn’t used my P4 since last summer. When I first started using it I was getting messages to update the firmware and software. But I delayed doing that as I was out in the field at the time. Everything worked great on the drone. I flew it around quite a bit and had no problems whatsoever A few weeks later I went out and this time decided to go ahead and accept the updates. After going through all of them I started having problems right away. Particularly, specifically with return to home. But I also had issues with changing direction, specifically going forward. It would reverse and go side to side just fine. But for some reason it would slow down going forward to a crawl. If I hit return to home it would go straight up until I eventually stopped it. then other times it would just come straight down until I stopped it. I turned off obstacle avoidance in other intelligent guidance functions but left vision control and GPS enabled. Made no difference with a exception of going forwards seem to be cured by turning off intelligent controls with those two exceptions. But the return to home feature still does not work. I have to manually guide it back to me and bring it down for a landing. I’m not happy about this since It reduces my ability to have faith in the software. Plus I want to know the drone will return to me if something goes on where it needs to return home. Clearly this occurred after I updated the firmware. I have exhausted everything I can think of in terms of calibration performing both calibration on the drone itself and on the remote control. Any answers out there?

1 Like

I’m having the exact issue. Would love an answer. I’ve reached out to DJI but haven’t heard back from them yet.

1 Like

After working with a few people on this issue, I found reverting the Phantom firmware to the previous version (or any version prior to 2.00.0700) resolves this issue. That can be done from the DJI Assistant 2 application (download it here).

1 Like

I also had similar problem. Using latest FW on P4, I think is 2.00.0810. So I should downgrade to 2.00.0700 or even older?

The people I talked to were all running 2.00.0810. Since lots of people are currently running 2.00.0810, I can only assume there is a certain setting or combination of settings that causes this to occur.

Another possibility is that DJI fixed the problem and re-released 2.00.0810 with a patch. If you want to verify, you could downgrade to 2.00.0700 and then upgrade back to 2.00.0810.

I will try later downgrade to 2.00.0700 and check if problem persist. Because I also got slow speed forward when OA is enabled… like ~10kph speed :confused:

So… I downgraded to 2.00.0700, did factory reset and looks like everythink is working. And actually have some features that I was unable to see previously. Like precision landing option or remote indentification… Maybe those where removed in latest FW?

2 Likes

Hello to all, I can’t get my dji pro 3 to take an update. everything seems to work except for camera video. when trying to update the firmware it starts okay the Gimbal has the alternating red and green light then after about 30 seconds it turns to red. maybe if I do the factory reset then upgrade it would help.
what are the steps to do the factory reset? this will be something more I could try.
Thanks

@dji-rey You may want to start a new thread on your issue. This is a different topic. That, said can you supply the AB installation log?

Thanks

I have the same issue, how was this fixed?

I am having the exact same issue with my P4, but did find a way to sort of fix the problem.

I turned off OA on RTH, but left overall OA on. RTH now works, though I would still like to fix the problem completely.

What is OA? I solved the issue by downgrading firmware… Never updating firmware ever again until I die haha

OA stands for Obstacle Avoidance

I am having same issue with P4/. Updated P4 , RC all good. So I have set RTH to 30 + height. I also put it in course lock. So course lock works perfect then I hit RTH P4 goes far above preset height to max. No return. Then also I don’t know if bc I hit RTH it was supposed to be taken out of course lock. I’m finding forward is to a crawl as well. All similar to what everybody is posting here. Any help greatly appreciated. I’m worried about flying it at all with all these issues. Thanks …

1 Like